ReleaseNotes:Planimate 4.97 Release Notes

From Planimate Knowledge Base
Jump to: navigation, search

4.97j


BUGFIX: Special handling added so an immediate message sent during a track lookahead (useful for making permanent changes to attributes/tables in lookahead) wont mess up the original train's route information (section tokens were being discarded)

4.97i


BUGFIX: When a user defined menu was used and the model was changed back to editor mode from user mode the side bar would be redrawn before the menu was regenerated. Thus the sidebar would be pushed down for the menu. Now fixed.
NEW: New INI file option "ModuleFolder" defines the folder Planimate will first look in when loading a module. ModuleFolder="Modules" (will look in {exe path}\Modules)
BUGFIX: End User menu display options were being ignored (ie Hide Load/Save Model)
NEW: New End User option "Hide Window Option", Hides the window menu when in end user mode.

4.97h


NEW: fixed cell stats logging and label list management
NEW: "Graphics" menu option now availalbe in the multiple selection menu that appears when a group of objects is left clicked.
This enables the "graphics" properties of all the selected objects to be set at once, which means border style, background, text and border colours and gradient colours.
The graphics dialog will default to the graphical settings of the object that was selected first in the selection group.
Only paint objects and views have "Graphics" properties, other selected objects will be unaffected by this option.
NEW: The defaults for the "graphics" copy/paste buffer can be set using new options in the INI file
(styles are numbered from 0 as they appear in the menu, colours are numbered from 0)
[Edit] DefaultBorderStyle=5 DefaultBorderColor=0 DefaultBackgroundColor=15 DefaultTextColor=0 DefaultTopLeftGradientColor=7 DefaultTopRightGradientColor=7 DefaultBottomLeftGradientColor=7 DefaultBottomRightGradientColor=7
NEW: Routine op to set Column text alignment mode can be set Index codes are: 0 = left 1 = right 2 = centre

4.97g


NEW: The "Save Window Image" change object File operation can now write to the clipboard.
Supply a filename of just "-" (using the dynamic filename option and a label list) and instead of the bitmap being written to a file, it will be placed into the clipboard, from which the user can paste the image into a graphics application.
CHANGE: Comparison precision changed from 1e-10 to 1e-12. This means equality checks require 12 digits of precisions to match
If a model computes one value from fractional components and compares it to a number computed differently, they may not exactly match.
Solutions include using "Round" on the computed numbers and avoiding code that expects *exact* values to be reached, but rather tests for thresholds being crossed.
BUGFIX More issues with data menu items when viewing application panel fixed
BUGFIX Added alternative "go back" handling for panel navigator when its docked - the existing mechanism broke when the navigator is in the dock because the navigator never gets activated/deactivated message.
These means go back (ctrl-b) and ctrl-d/ctrl-f will work for all panels visited using the docked navigator.
CHANGE: Cell-Stat Views no longer "track" their cell as rows are added/deleted from the table. They stay hard-coded to the cell they were initially associated with
CHANGE Change object menu "lookahead" option now more descriptive and uses a flyout rather than the option popup
CHANGE INI files now support strings
New INI setting
[INI] DefaultFolder="."
Sets initial working folder for PL (default is the folder set by the shortcut, which is usually the exe's folder
NEW: If the display option to not auto start scheduled entries has been selected and the model hasn't started the entries yet, then a new item in the paused background click menu enables the modeller to start them.
NEW: Table routine operation "Purge Duplicate Rows"
Removes any identical rows after the first one encountered.
Comparisons are made using Planimate's rounding rules (now 12 digits precision). This will create issues for values over 12 digits long, with different round off error or with long multilabels.



4.97f


BUGFIX About box shows user bmps properly for PBAs
BUGFIX Issues in routine editor of condition editor enabling parent windows to be clicked/closed causing crash now fixed
(Screens were propagating "Enable()" up to parent Screens; now dont do the propagate if the parent screen is also a Form class)
BUGFIX Views (eg table) will not copy paste between models directly; (they need to be in a portal with their table) this is now checked, (including multi-selections) and the copy/paste buffer is discarded if it contains a view when another model is loaded

BUGFIX: Planimate Help menu commands would only find the Planimate help file if there was no model loaded (ie current path = exe path) now works with model loaded.
CHANGE: Planimate will now first search for a folder called "Help" under the search path to find help files.

4.97e


NEW About box shown for all versions of PL including standalone applications (gets shown for 5 seconds)
NEW Application key files for creating internally keyed applications become unusable after the EXE is a year newer than the application key.
NEW Planimate has more sophisticated INI file handling
To better support multiple users, the INI file is now created by default within the users "Application Data" folder. I still support INI files in the EXE folder however, so no action is required if you are happy with the INI file where it is. The INI file has also been renamed.
The search works as follows:

  • look in the EXE directory for "PLANIMATE.INI" If not found, then
  • look in the EXE directory for "PLANIMAT.INI" If not found, then
  • look in "Documents And Settings\(username)\Application Data\InterDynamics\Planimate" for "Planimate.INI"

If all these fail to find an INI file, then PL will default to creating one in the Application Data folder, as above.
If PL does find an INI file, it then writes back to that location.

4.97d


CHANGE: More changes to about box
Application name is shown at top left of application bitmap area for standalone exes
No nags on expiring of PL Model End User ("InterDyne") key files
A keyfile with an application name associated can only be used with a standalone EXE with that application name (not as PL End user key)
PL Modellers do not get option to create applications with external key files UNLESS they have ability to create unkeyed applications. It is intedned that most developers would create/ship PBAs which have been internally keyed with a PBA license key.
BUGFIX Display of routine atts and purging during copy to a sub-routine fixed
BUGFIX IDBase menu status once connected
BUGFIX Data attribute/table items now always available and bind to closest dynamic screen's data when in a view panel
CHANGE "Average" field for constant value distribution now labelled "Value"
NEW Breakpoint/error dialog now remembers its position during a PL session
NEW "Step" button in breakpoint dialog - next routine line executed will be breakpointed before it executes
BUGFIX "Draw from top" gantts now work properly with the y scrollbar
CHANGE: most recent list of models available in user mode again
NEW Value format "Scientific"
formats values as: 1.23

4567e

-003
Unlike all other value formats, no clipping or rounding is performed on numbers read/written using this format. Currently is fixed at 6 decimal digits of precision.
NB: PL is not intended for processing of very small or huge numbers and most of the other formats do rounding/clamping of values to protect modellers and users from some roundoff issues.

4.97c


CHANGE: Reworking about box, inner about box and PBA about box
NEW: Basic List of Logged Stat Displays under View menu select "View Logged Stats"

4.97b


CHANGE: Modules looking for module configuration screens will no longer search within other modules.
CHANGE: Object names are updated in the treeview when a new object name is created
CHANGE: date testing for keyfiles fixed
NEW: ability to enable/disable lines in a routine (ie: comment them out)
[somewhat tested]
this is intended for immediate debugging and wont be saved in the model file. If you want something persistent, then use an IF.
Lines are disabled using their context menu during edit or by double clicking or right clicking on them during simulate
A disabled line has a "-" in front of its line number
Disabling a WHILE, SELECT or ITERATE disables all code within it (this isn't indicated though)
Disabling an IF disables its ELSE as well Disabling an ELSE disables just the else part
Disabling on an ENDIF, ENDWHILE etc is ignored. Disabling a CASE is not yet supported
I am interested of any speed difference in routine processing with this release compared to

4.97a

.
Disabling a line in an instance of a shared routine during simulate will be lost when the run restarts, otherwise disabled lines persist between runs.

4.97a


NEW: Routine operation Spatial link - Add Spatial Link Bend
enables a bend point to be appended to the current bend points of any spatial link going from one designated portal to another.
This is intended for models which construct spatial link networks on the fly. There is no way to remove a bend point; recreate the link as required.
CHANGE: "Use mouse position" co-ordinate for popping up a panel in a routine change from (-9999,-9999) to (-1,-1) as what is used in a popup panel button click action.
Models using (-9999,-9999) introduced in

4.96m

need to be updated

CHANGE: Table scrollbars remain operational if the mouse leaves their region as the mouse is dragged.
NEW: Easier to delete a distribution scaling value (delete button in attref dialog)
NEW: Note in routine editor given for bitwise and modulus re: 14 digit limit
BUGFIX: Fixed PL showing and forgetting about the "advance to time" dialog if an error occured durng the initialisation of the model.
BUGFIX: Locating broadcast button paint objects from the broadcast now implemented
4.97
NEW: Edit -> End User Model Info
has new "Application name" field. This sets default application name used when creating a keyed standalone EXE.

NEW: Key file format. Now have account name field. Names can be longer
New format key files are 248 bytes.
key files now have up to 50 char names new fields for account name and application name in key files and demo/edu version bits date testing performed for demo/edu/runtime versions
PL still compatible with older key files (account name = user name)
Newer key files implement expiry/aging
No longer need DLL to make standalone applications
You will need special key file to create internally keyed standalone EXE - contact TonyG about this

CHANGE: Panel (Dynamic / Application) Object names appear in the treeview. An ini option controls this: TreeViewObjectNames=1 (1 to turn on, 0 to turn off)


idkbase note 307